Php Của Bạn Không Hỗ Trợ Mysql, Wordpress Cần Có Mysql Để Chạy.

WordPress là 1 trong nền tảng cực kì mạnh mẽ và an toàn để làm chủ trang web của bạn. Tuy nhiên, có một vài vấn đề thông dụng và thông tin lỗi mà chúng ta cũng có thể gặp phải, chẳng hạn như “Cài để PHP của bạn bên cạnh đó bị thiếu phần mở rộng MySQL nhưng WordPress yêu thương cầu“ / Your php installation appears lớn be missing the mysql extension which is required by wordpress.

Bạn đang xem: Php của bạn không hỗ trợ mysql, wordpress cần có mysql để chạy.

Như với bất kỳ thông báo lỗi WordPress như thế nào , chúng ta có thể khó chịu đựng khi chạm mặt sự thế ngăn bạn sử dụng/truy cập trang web WordPress của mình.

Nói chung, lỗi này có nghĩa là có nào đó đang chống WordPress ko thể kết nối với cơ sở dữ liệu MySQL trên host.


Mục lục

Điều gì tạo ra lỗi WordPress thiếu một thể ích mở rộng MySQL?Cách khắc phục và hạn chế “Your php installation appears to lớn be missing the mysql extension which is required by wordpress.”

Điều gì gây ra lỗi WordPress thiếu tiện thể ích mở rộng MySQL?

Lỗi "Your php installation appears khổng lồ be missing the mysql extension which is required by wordpress" có nghĩa là PHP trên sản phẩm công nghệ chủ của người sử dụng không bao gồm phần mở rộng quan trọng để kết nối trang web WordPress của doanh nghiệp với cơ sở dữ liệu MySQL của chính nó .

1. Ai đang sử dụng phiên bạn dạng lỗi thời của WordPress với PHP 7+

Các phiên bạn dạng cũ hơn của WordPress (dưới phiên bản 3.9) có thể gây ra sự thế này.

Bạn rất có thể nhờ đơn vị hosting/ Hoặc Stream Hub thiết lập PHP 7+ hoặc nâng cấp Wordpress lên version 6. Trở lên.

2. Nhiều người đang sử dụng PHP 5.6 trở xuống mà lại tiện ích mở rộng bị thiếu hụt hoặc thông số kỹ thuật không đúng

Nguyên nhân hoàn toàn có thể khác là ai đang sử dụng PHP 5.6 (trước lúc tiện ích không ngừng mở rộng MySQL không được sử dụng nữa), cơ mà tiện ích mở rộng bị thiếu thốn hoặc được định thông số kỹ thuật không đúng.

Cách khắc chế “Your php installation appears khổng lồ be missing the mysql extension which is required by wordpress.

Bây giờ các bạn đã biết điều gì sẽ xảy ra, hãy xem qua một số mẹo về cách gỡ rối và khắc phục sự cố.

Kiểm tra phiên bản PHP nhiều người đang sử dụngCập nhật phần mềm WordPress coreKiểm tra xem tiện ích không ngừng mở rộng MySQL sẽ được thiết đặt chưaĐảm bảo nhân tiện ích không ngừng mở rộng PHP được định thông số kỹ thuật đúng

1. đánh giá phiên phiên bản PHP ai đang sử dụng

Bước thứ nhất để chẩn đoán vấn đề này là tìm ra phiên bạn dạng PHP nào mà máy chủ trang web WordPress của công ty đang chạy. Câu trả lời cho câu hỏi này vẫn quyết định các bước tiếp theo mà các bạn thực hiện.

Để soát sổ điều này, hãy liên kết với sever của trang web WordPress của người tiêu dùng bằng FTP . Chúng ta có thể lấy tin tức đăng nhập FTP từ máy chủ lưu trữ web của chính mình và bạn cũng sẽ cần một vận dụng khách FTP để kết nối.

Nếu trang bị chủ của doanh nghiệp đang sử dụng cPanel , chúng ta có thể sử dụng pháp luật Trình cai quản tệp cPanel.

Khi chúng ta đã kết nối với sever của mình, hãy chế tạo ra một tệp mới mang tên phpinfo.php trong thư mục nơi bắt đầu của trang web WordPress của bạn. Đây đề nghị là cùng một thư mục chứa tệp wp-config.php của bạn.

Sau đó, chỉnh sửa tệp cùng thêm đoạn mã sau:

Sau khi chúng ta lưu tệp (và download lên lại phiên bạn dạng đã lưu ví như cần), hãy điều tìm hiểu yoursite.com/phpinfo.php, đảm bảo thay cầm cố yoursite.com bởi tên miền thực của bạn.

Bạn vẫn thấy một màn hình hiển thị hiển thị nhiều thông tin khác nhau về thông số kỹ thuật PHP trên máy chủ của bạn. Cuộn xuống phần Lõi cùng tìm mục Phiên phiên bản PHP. Hãy chăm chú đến các con số – bạn sẽ thấy một cái nào đấy giống như xxx Ví dụ: 7.2.25 hoặc 5.6.8:

Bạn ý muốn biết làm cụ nào shop chúng tôi tăng lưu lại lượng truy tìm cập của chính bản thân mình hơn 1000%?

*
phương pháp kiểm tra phiên bạn dạng PHP của website WordPress của bạn

Nếu phiên bạn dạng PHP của bạn bước đầu bằng số “7”, điều đó thường có nghĩa là bạn cần cập nhật phần mượt WordPress. Mặt khác, nếu như khách hàng vẫn đang thực hiện PHP 5.X, có thể bạn vẫn thiếu phần mở rộng MySQL.

Tại các website được Stream Hub cai quản lý, cửa hàng chúng tôi đều mua phiên bạn dạng PHP bình ổn nhất!

2. Cập nhật phần mềm chip core WordPress

Nếu sản phẩm công nghệ chủ của khách hàng đang thực hiện PHP 5+, lý do rất hoàn toàn có thể gây ra lỗi này là do bạn đang hoạt động phiên bạn dạng cũ của WordPress .

Do đó, biện pháp khắc phục là cập nhật phần mềm WordPress của bạn, ứng dụng này cũng sẽ đi kèm cùng với nhiều cách tân về tính năng, bảo mật và năng suất khác .

Xem thêm: 8 Mẫu Cảm Nhận Về Bài Thơ Tràng Giang Của Huy Cận, 8 Mẫu Cảm Nhận Bài Thơ Tràng Giang Siêu Hay

Để tăng cấp phiên bạn dạng WordPress của người sử dụng theo bí quyết thủ công, trước tiên, hãy đảm bảo rằng chúng ta có phiên bạn dạng đã sao giữ của trang web của chính bản thân mình . Sau đó, truy vấn WordPress.org và mua xuống phiên bản sao mới nhất của ứng dụng WordPress.

Khi các bạn đã cài xuống, hãy giải nén tệp tin nén vào máy vi tính của bạn. Sau đó, mở thư mục chứa tất cả các tệp WordPress với xóa các mục sau:

Tệp wp-config-sample.php.Tệp wp-config.php (bạn rất có thể không thấy tệp này – chỉ cần bảo đảm xóa tệp trường hợp có).Thư mục văn bản wp.

Khi chúng ta đã xóa những mục đó, hãy tải những tệp/thư mục sót lại lên vật dụng chủ của người tiêu dùng qua FTP. Khi được áp dụng khách FTP của người tiêu dùng nhắc về những tệp trùng lặp, hãy yêu ước nó ghi đè lên tất cả các tệp:

*
thiết đặt lại WordPress bằng cách ghi đè lên những tệp hiện có

Khi quá trình tải tệp lên hoàn tất, trang web WordPress của các bạn sẽ chạy phiên bản mới nhất với sự rứa của các bạn sẽ được tương khắc phục.

Đấu tranh với thời hạn chết và các vấn đề về WordPress? dịch vụ của Stream Hub là giải pháp giúp bạn tiết kiệm ngân sách thời gian! mướn Stream Hub xử trí ngay

3. Update theme cùng plugins lên version bắt đầu nhất

Bạn hoàn toàn có thể thực hiện nay trong wp-admin!

Cách update plugin WordPress: vào plugins -> updateCách cập nhật theme WordPress: vào theme -> update

4. Bình chọn xem tiện thể ích không ngừng mở rộng MySQL sẽ được setup chưa

Nếu sản phẩm chủ của bạn vẫn đang thực hiện PHP 5.6 trở xuống, máy chủ của chúng ta cũng có thể thiếu phần không ngừng mở rộng MySQL cơ mà WordPress yêu cầu.

Để soát sổ xem đây liệu có phải là trường hòa hợp không, hãy quay lại tệp phpinfo.php mà các bạn đã cài đặt lên vật dụng chủ của bản thân mình ở bước #1.

Tìm phần mang tên mysql hoặc mysqli.

Nếu nhân thể ích không ngừng mở rộng MySQL được cài đặt, các bạn sẽ thấy số phiên bạn dạng bên cạnh mục phiên bạn dạng thư viện API vận dụng khách:

*
giải pháp xem luôn thể ích mở rộng WordPress MySQL đã được cài đặt chưa

Nếu chúng ta không thể tìm kiếm thấy thông tin này, điều đó có nghĩa là tiện ích không ngừng mở rộng MySQL chưa được cài đặt. Giải pháp tốt độc nhất thường là liên hệ với nhân viên cấp dưới hỗ trợ của máy chủ lưu trữ và yêu cầu họ setup nó mang lại bạn.

Lưu ý – một lần nữa, shop chúng tôi khuyên bạn không nên sử dụng các phiên phiên bản PHP dưới 8.0 vì chúng không còn nhận được các bạn dạng cập nhật bảo mật và không hoạt động tốt như các phiên phiên bản mới rộng .

Trừ khi bạn trọn vẹn phải liên tục sử dụng PHP 7.4 hoặc tốt hơn, chiến thuật tốt hơn các là tăng cấp máy chủ của người tiêu dùng lên PHP 8+ thay do dành thời gian để định thông số kỹ thuật đúng phiên phiên bản PHP cũ hơn. Bạn có thể làm theo phía dẫn của công ty chúng tôi về cách cập nhật phiên bạn dạng PHP của website WordPress của chúng ta và cách thiết lập PHP trên ngẫu nhiên máy công ty nào.

5. Đảm bảo phần mở rộng PHP được định cấu hình đúng cách

Nếu bạn đang sử dụng PHP 5.6 trở xuống và tiện ích mở rộng đã được sở hữu đặt, vấn đề rất có thể là nó ko được định thông số kỹ thuật đúng cách. Nhì vấn đề thịnh hành là:

Tải lên tệp php.ini dành riêng cho máy nhà Windows khi bạn đang sử dụng sever LinuxĐường dẫn tệp không chủ yếu xác.

Bạn rất có thể tìm thấy vị trí của tệp php.ini trong tệp phpinfo.php mà chúng ta đã tạo trước đó:

*
phương pháp tìm đường dẫn tệp WordPress php.ini

Trước tiên, cửa hàng chúng tôi khuyên bạn nên sao lưu lại tệp hiện tại có bằng phương pháp tải tệp đó xuống lắp thêm tính cục bộ của bạn. Sau đó, hãy thử xóa tệp php.ini cùng xem cách đó có khắc phục được sự ráng không.

Kết luận

Thông báo “Cài để PHP của bạn trong khi bị thiếu nhân thể ích không ngừng mở rộng MySQL được yêu thương cầu bởi WordPress” là một trong những lỗi khó chịu vì nó dường như quá kỹ thuật.

Tuy nhiên, với quá trình trong bài viết này, các bạn sẽ có thể chẩn đoán với khắc phục sự cố.

Giải pháp được lời khuyên của công ty chúng tôi là bảo đảm rằng nhiều người đang sử dụng các phiên phiên bản mới nhất của tất cả PHP với WordPress.

Nếu áp dụng PHP 8+ cùng WordPress 5.0+, các bạn sẽ có thể tự động sửa lỗi này với giúp trang web của mình vận động trở lại, đôi khi hưởng lợi từ tất cả các cải tiến về hiệu suất, bảo mật và nhân kiệt khác gồm được từ các việc cập nhật.

Tiết kiệm thời gian, ngân sách và buổi tối đa hóa hiệu suất trang web với:

Trợ góp tức thì trường đoản cú các chuyên gia lưu trữ WordPressTích hòa hợp Cloudflare.Theo dõi 24/7

Tất cả những điều đó và hơn thế nữa nữa, hay xem qua những dịch vụ của cửa hàng chúng tôi hoặc rỉ tai với bộ phận bán sản phẩm để tìm kiếm kế hoạch cân xứng với bạn.